Forum

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Emails without junk percentage (blank, not zero)
January 16, 2010
11:45 am
TiagoTiago
Member
Members
Forum Posts: 5
Member Since:
January 16, 2010
sp_UserOfflineSmall Offline

can you make it so Junkilla automaticly fix emails with blank junk percentage when found?

in my case i think the most common is that the msgs without a junk percentage value have been moved from folder form another account by message filters, i'm not sure if it's the only cause

(this thing with hte forum layout being broken and hiding part of the contents is  a pain indeed 🙁  )

January 16, 2010
1:38 pm
Admin
Moderators
Forum Posts: 423
Member Since:
July 12, 2008
sp_UserOfflineSmall Offline

I occasionally see emails that obviously did not go through junk mail processing as well. Without JunQuilla you never notice that, as they just appear as normal good emails.

But I would hate to try to fix a bug in the core by adding some feature to JunQuilla. I would rather do that by fixing the root cause in core, though I have no idea what is causing this nor how to reproduce it. I suspect that somehow the system gets too busy, and as a result the junk filter is unable to get the copy of the message that it needs to analyze for junk.

As to FiltaQuilla, it would be quite easy to add a filter action to analyze a message for junk. I've added it to my list of requests. Then you could at least try adding a filter, which would need to be post-classification, that tries to detect a message that did not get analyzed, and request again that it be analyzed.

I wish I knew how to reproduce your issue with the forum display. Maybe I'll look in the forum support newsgroups and see if anyone else has had this issue.

January 16, 2010
2:38 pm
TiagoTiago
Member
Members
Forum Posts: 5
Member Since:
January 16, 2010
sp_UserOfflineSmall Offline

weird, not it fits just fine, even the textbox for replying (though the toolbar for composition does look like it doesn't quite fit)

actually, it seems one or two chars on the right side of the line might get beyoond the edge here somtimes but it isn't easy to repro for some reason

as for the filter, would it work to do the analysis of the content of messages and both add the junkmail percentage and send it to the junkfolder if it is beyond the threshold? And is it possible to have a filter run after the junkmail filter instead of before?

January 16, 2010
4:57 pm
Admin
Moderators
Forum Posts: 423
Member Since:
July 12, 2008
sp_UserOfflineSmall Offline

What a possible future custom filter action in FiltaQuilla could do easily is to kick off standard junk mail processing, nothing more.

But you can run filters after junk mail processing, and not before. That is done by selecting "after classification" when you setup the filter. The main thing that this does is to make the junk-related search terms available (junkpercent, junkstatus, and junkscoreorigin). Using those terms, you could take arbitrary action on the email. None of that depends on JunQuilla by the way, though I did do the core implementation of the "after classification" feature.

January 16, 2010
8:47 pm
TiagoTiago
Member
Members
Forum Posts: 5
Member Since:
January 16, 2010
sp_UserOfflineSmall Offline

will a filter be able to identify the difference between not having a junk percent and havign zero% of junk probability?

January 18, 2010
9:43 am
Admin
Moderators
Forum Posts: 423
Member Since:
July 12, 2008
sp_UserOfflineSmall Offline

This is much more difficult than it should be (and I should really fix that in core). I was able to do this with a series of (junkstatusorigin ISNT ...) filters, filling in all of the valid junstatusorigin values (whitelist, plugin, user). If the bayes filter sets it, the origin is plugin.

January 18, 2010
10:02 am
Admin
Moderators
Forum Posts: 423
Member Since:
July 12, 2008
sp_UserOfflineSmall Offline

I filed core Bug 540449 to deal with this issue.

Forum Timezone: UTC -8

Most Users Ever Online: 41

Currently Online: ritaHinc
2 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

BigMike: 14

David.P: 10

Jeff Wexler: 9

taa: 8

JPRuehmann: 8

bobkatz: 8

Member Stats:

Guest Posters: 217

Members: 2350

Moderators: 2

Admins: 1

Forum Stats:

Groups: 1

Forums: 7

Topics: 375

Posts: 1220

Newest Members:

AlbertKet, Kevintuh, LazaroVag, elinorgb1, Niki1Kevick, AnthonyPaino

Administrators: rkent: 423