Forum

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Ver 1.1.1 and Thunderbird 24.3.0 Linux - Internal versus External Sound Player
March 17, 2014
6:47 pm
NTL2009
Member
Members
Forum Posts: 3
Member Since:
March 17, 2014
sp_UserOfflineSmall Offline

First, thanks for this add-on! I find it very useful.

In previous versions of ToneQuilla, the selected sound file would open the associated sound player application, and that would play the sound (Totem Movie Player in my case).

After a recent update of my Xubuntu 12.04 system, TQ stopped working. After playing around, I found it worked if I converted the sound files to ".ogg" format. Later, I realized that it seemed to use an internal player, rather than loading the Totem Movie Player application.

Now that may sound like an enhancement, but... if I don't happen to hear the sound, I have nothing to 'flag' me that an email that triggers sounds arrived, and I might miss it for some time. Previously, the sound application would be 'flashing' in my notification bar, and that would alert me as well.

So - is there a way to force TQ to use an external player?

TIA - NTL2009

March 18, 2014
8:37 am
Admin
Moderators
Forum Posts: 423
Member Since:
July 12, 2008
sp_UserOfflineSmall Offline

ToneQuilla, as you suspected, uses an internal Mozilla sound player for files of type audio/wav, uses another internal Mozilla player for audio/ogg, and hands the file to the operating system for any other MIME type. If the extension type is .wav, then the MIME type is forced to be "audio/wav". For any other file extension, ToneQuilla just hands the file to the operating system.

I assume that the problem you are having is that for some reason the Mozilla method that plays .wav files is broken on your system, but launching by the OS works. For a workaround, you could try any of the following:

1) Renaming the files to a different extension, then using OS tools to select which app to use to play

2) Instead of using Tonequilla, use Filtaquilla which has an explicit "Launch File" filter action. This does virtually the same thing that Tonequilla does with non-recognized file types, and could be used to force playing of a .wav file using the OS player rather than the internal Mozilla player.

March 18, 2014
9:44 am
NTL2009
Member
Members
Forum Posts: 3
Member Since:
March 17, 2014
sp_UserOfflineSmall Offline

Thanks for the speedy reply.

I should add, when I set a TQ filter to play an mp3 file, it opens the TQ sounds directory (~/.thunderbird/4eemizsg.default/extensions/tonequilla@mesquilla.com/sounds/glass-clink-1.mp3) with the file manager, and the file is highlighted (selected) but does not play the sound. When I select a .wav, it does nothing (that I can see/hear). I have .ogg , .wav and .mp3 all set to open with Movie Player (Totem) by default. The .ogg files appear to play internally within Thunderbird.

But I will try Filtaquilla and report back - sounds like (no pun intended) that has the flexibility I'm looking for (I might even get fancier with a text file flag in addition to alert sounds for incoming emails that I filter).

Thanks, NTL2009

June 13, 2014
6:23 pm
NTL2009
Member
Members
Forum Posts: 3
Member Since:
March 17, 2014
sp_UserOfflineSmall Offline

rkent said ....
2) Instead of using Tonequilla, use Filtaquilla which has an explicit "Launch File" filter action. This does virtually the same thing that Tonequilla does with non-recognized file types, and could be used to force playing of a .wav file using the OS player rather than the internal Mozilla player.

I finally found some time to try Filtaquilla in place of Tonequilla (been busy with my Xubuntu 14.04 installs/tweaking).

Unfortunately, it seems to act the same for me as Tonequilla - when I set the "action" to "Launch File", and click the "Launch selected file" icon, it simply opens the parent directory in the default file manager, and the specified file is highlighted, but not launched.

For simplicity, I tried filenames/directories with no spaces and placed them in my home (username) directory. I tried a plain text file and sound files (separately). I tried making a launcher for the selected textfile (Exec=gedit /home//MAIL-FROM-KIDS.txt) , same thing - the file is just highlighted in the file manager.

Any ideas?

Thanks, NTL2009

Forum Timezone: UTC -8

Most Users Ever Online: 41

Currently Online:
7 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

BigMike: 14

David.P: 10

Jeff Wexler: 9

taa: 8

JPRuehmann: 8

bobkatz: 8

Member Stats:

Guest Posters: 217

Members: 5053

Moderators: 2

Admins: 1

Forum Stats:

Groups: 1

Forums: 7

Topics: 383

Posts: 1228

Newest Members:

GeorgeKex, OlgaBak, CichockiRor, KounthapanyaRor, QLRobert, Daylibum

Administrators: rkent: 423